题解:Tic Tac Toe(模拟)

Tic Tac Toe is a child’s game played on a 3 by 3 grid. One player, X, starts by placing an X at an unoccupied grid position. Then the other player, O, places an O at an unoccupied grid position. Play alternates between X and O until the grid is filled or one player’s symbols occupy an entire line (vertical, horizontal, or diagonal) in the grid.
We will denote the initial empty Tic Tac Toe grid with nine dots. Whenever X or O plays we fill in an X or an O in the appropriate position. The example below illustrates each grid configuration from the beginning to the end of a game in which X wins.
… X… X.O X.O X.O X.O X.O X.O

… … … … .O. .O. OO. OO.

… … … …X …X X.X X.X XXX

Your job is to read a grid and to determine whether or not it could possibly be part of a valid Tic Tac Toe game. That is, is there a series of plays that can yield this grid somewhere between the start and end of the game?
Input
The first line of input contains N, the number of test cases. 4N-1 lines follow, specifying N grid configurations separated by empty lines.
Output
For each case print “yes” or “no” on a line by itself, indicating whether or not the configuration could be part of a Tic Tac Toe game.
Sample Input
2
X.O
OO.
XXX

O.X
XX.
OOO
Sample Output
yes
no
情况要考虑全面

#include <iostream>
#include <stdio.h>
using namespace std;
const int N = 3;
char grid[N][N + 1];
bool judge(char c)
{
    int j;
    for(int i = 0; i < N; i++) 
	{
     for(j = 0; j < N && grid[i][j] == c; j++);
      if(j == N)
        return true;
	 for(j = 0; j < N && grid[j][i] == c; j++);
      if(j == N)
        return true;
    }
   for(j = 0; j < N && grid[j][j] == c; j++);
    if(j == N)
     return true;
    for(j = 0; j < N && grid[j][N - 1 - j] == c; j++);
    if(j == N)
        return true;
    return false;
}
int main()
{
    int n;
    scanf("%d", &n);
    while(n--) 
	{
     int xcnt = 0, ocnt = 0;
     for(int i=0;i<3;i++)
      for(int j=0;j<3;j++)
      {
   	   cin>>grid[i][j];
   	   if(grid[i][j]=='X') xcnt++;
   	   else if(grid[i][j]=='O') ocnt++;
      }
       if(xcnt<ocnt||xcnt-ocnt>1||(judge('O')&&ocnt!=xcnt)||(judge('X')&&xcnt-ocnt!=1))
         cout<<"no"<<endl;
        else cout<<"yes"<<endl; 
    }
    return 0;
}

上一篇:CF1450C1 Errich-Tac-Toe (Easy Version)/CF1450C2 Errich-Tac-Toe (Hard Version)


下一篇:No More Tic-tac-toe