M - Sekiro

Description

Sekiro: Shadows Die Twice is an action-adventure video game developed by FromSoftware and published by Activision. In the game, the players act as a Sengoku period shinobi known as Wolf as he attempts to take revenge on a samurai clan who attacked him and kidnapped his lord.

As a game directed by Hidetaka Miyazaki, Sekiro (unsurprisingly) features a very harsh death punishment. If the player dies when carrying gg amount of money, the amount of money will be reduced to ⌈g2⌉⌈g2⌉, where ⌈g2⌉⌈g2⌉ indicates the smallest integer g′g′ that 2g′≥g2g′≥g.
As a noobie of the game, BaoBao has died kk times in the game continuously. Given that BaoBao carried nn amount of money before his first death, and that BaoBao didn’t collect or spend any money during these kk deaths, what’s the amount of money left after his kk deaths?

Input

There are multiple test cases. The first line of the input contains an integer TT (about 103103), indicating the number of test cases. For each test case:
The first and only line contains two integers nn and kk (0≤n≤1090≤n≤109, 1≤k≤1091≤k≤109), indicating the initial amount of money BaoBao carries and the number of times BaoBao dies in the game.

Output

For each test case output one line containing one integer, indicating the amount of money left after kk deaths.

Sample Input

4
10 1
7 1
10 2
7 2

Sample Output

5
4
3
2

Hint

For the third sample test case, when BaoBao dies for the first time, the money he carries will be reduced from 10 to 5; When he dies for the second time, the money he carries will be reduced from 5 to 3.

题目大意

对一个数字求若干次除2取上界
确实是有点水…直接暴力,循环特判一下

AC代码

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int main()
{
    ll t,n,m;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        while(m--)
        {
            n=(n%2)?n/2+1:n/2;
            if(n==1||n==0)
                break;
        }
        cout<<n<<endl;
    }
}

上一篇:#C++初学记录(acm试题#预处理)


下一篇:android上的颜色选择 – glReadPixels舍入错误