K - GCD Again【欧拉函数】

Discription
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a “Big Cattle”.
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!

Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.

Sample Input
2
4
0

Sample Output
0
1

题意
给定一个N
求在 M (0<M<N)的条件下
(N,M)>1成立的个数

思路
开始把问题想复杂了,想用【唯一分解定理+容斥定理】做,然后写了半天没改出来。
后来发现,题的意思是求与N不互质的数的个数,那就直接可以用欧拉函数求出互质的个数,然后用N-1减去互质的个数。

AC代码

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
///直接求解一个数n的欧拉函数
int euler(int n){ //返回euler(n)
       int res=n,a=n;
       for(int i=2;i*i<=a;i++){
           if(a%i==0){
               res=res/i*(i-1);//先进行除法是为了防止中间数据的溢出
               while(a%i==0) a/=i;
           }
       }
      if(a>1) res=res/a*(a-1);
      return res;
}
int n;
int main()
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        printf("%d\n",n-euler(n)-1);
    }
    return 0;
}
K - GCD Again【欧拉函数】K - GCD Again【欧拉函数】 爱吃老谈酸菜的DV 发布了271 篇原创文章 · 获赞 105 · 访问量 1万+ 私信 关注
上一篇:练习2-8 计算摄氏温度 (10分)


下一篇:最新版 IDEA激活码_idea激活码2021 免费提取_更新于2021-03-17