POJ 2189

Description:

Farmer John has two feuding herds of cattle, the Moontagues and the Cowpulets. One of the bulls in the Moontague herd, Romeo, has fallen in love with Juliet, a Cowpulet. Romeo would like to meet with Juliet, but he doesn't want the other members of the Cowpulet herd to find out. 

Romeo and Juliet want to meet and graze in as large a region as possible along the pasture fence. However, this region should not contain too many Cowpulets, otherwise the chance of the two being caught is too great. Romeo has determined where along the fence each of the N (1 <= N <= 1000) members of the Cowpulet herd grazes. The long straight fence contains P (1 <= P <= 1000) equally-spaced posts numbered 1..P. Each Cowpulet grazes between some pair of adjacent posts. Help Romeo determine the length of the largest contiguous region along the fence containing no more than C (0 <= C <= 1000) members of the Cowpulet herd. 

Input

* Line 1: Three separated integers: N, P, and C 

* Lines 2..N+1: Each line contains an integer X, in the range 1..P-1, specifying that a member of the Cowpulet herd grazes between fence posts X and X+1. Multiple Cowpulets can graze between any given pair of fence posts. 

Output

* Line 1: A single integer specifying the size (the number of gaps between fence posts) of the largest contiguous region containing at most C Cowpulets. 

Sample Input

2 6 1
2
3

Sample Output

3

题意:

这道题的题意是真的难理解。

就是n头牛,从1-p-1的距离中,求包含不大于c头牛的最大距离。

挺水的。

AC代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define maxn 1000005
using namespace std;
int a[1010];
ll n,m;
int i,j,k,l;
int p,c,x,ans,sum,cnt[1005];
int main()
{
    memset(cnt,0,sizeof(cnt));
    scanf("%d %d %d",&n,&p,&c);
    for(i=0; i<n; i++)
    {
        scanf("%d",&x);
        cnt[x]++;
        //cout<<cnt[x]<<endl;
    }
    //for(i=1;i<=p;i++)
       // cout<<cnt[i]<<endl;
    ans=0;
    sum=0;
    for(i=1; i<p; i++)
    {
        k=0;
        sum=0;
        for(j=i; j<p; j++)
        {
            if(sum+cnt[j]>c)
                break;
            else
            {
                sum+=cnt[j];
                k++;
                //cout<<k<<endl;
            }
        }
        //cout<<k<<endl;
        ans=max(ans,k);
    }
    printf("%d\n",ans);
    return 0;
}



 

上一篇:字符类型(Java)


下一篇:Fence