UVA839 Not so Mobile【递归树】

Before being an ubiquous communications gadget, a mobile was just a structure made of strings and wires suspending colourfull things. This kind of mobile is usually found hanging over cradles of small babies.

    The figure illustrates a simple mobile. It is just a wire, suspended by a string, with an object on each side. It can also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the lever principle we know that to balance a simple mobile the product of the weight of the objects by their distance to the fulcrum must be equal. That is Wl × Dl = Wr × Dr where Dl is the left distance, Dr is the right distance, Wl is the left weight and Wr is the right weight.
    In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure. In this case it is not so straightforward to check if the mobile is balanced so we need you to write a program that, given a description of a mobile as input, checks whether the mobile is in equilibrium or not.

Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
    The input is composed of several lines, each containing 4 integers separated by a single space. The 4 integers represent the distances of each object to the fulcrum and their weights, in the format: Wl Dl Wr Dr
    If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the following lines define two sub-mobiles: first the left then the right one.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
    Write ‘YES’ if the mobile is in equilibrium, write ‘NO’ otherwise.
Sample Input
1
0 2 0 4
0 3 0 1
1 1 1 1
2 4 4 2
1 6 3 2
Sample Output
YES

问题链接UVA839 Not so Mobile
问题简述
    给定一个杠杆两端的物体的质量和力臂,如果质量为零,则下面是一个杠杆,判断是否所有杠杆平衡。
问题分析
    本来是一个树的平衡问题,用递归来解决比较简单。这里的解题递归程序可以看作是在创建递归树,原理上与建树是相同的。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++程序如下:

/* UVA839 Not so Mobile */

#include <bits/stdc++.h>

using namespace std;

// 递归程序:输入并且判定平衡
int tree(bool& flag)
{
    int wl, dl, wr, dr;
    scanf("%d%d%d%d", &wl, &dl, &wr, &dr);
    if (!wl) wl = tree(flag);
    if (!wr) wr = tree(flag);
    flag = wl * dl == wr * dr ? flag : false;
    return wl + wr;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--) {
        bool flag = true;
        tree(flag);
        printf("%s\n", flag ? "YES" : "NO");
        if(t) printf("\n");
    }

    return 0;
}
上一篇:centos7安装gcc新版本


下一篇:【Rdis 基础内容+关键字 01】