PAT (Advanced Level) Practice 1019 General Palindromic Number (20 分) 凌宸1642

PAT (Advanced Level) Practice 1019 General Palindromic Number (20 分) 凌宸1642

题目描述:

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b ≥ 2, where it is written in standard notation with k+1 digits ai as ∑ki=0(aibi). Here, as usual, 0 ≤ ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

译: 向前或向后书写都是相同的数称为回文数 。例如 1234321 就是一个回文数。所有的单个数字的数都是回文数。

虽然回文数在十进制系统中考虑的最多,但是回文数的概念可以应用到任意自然数数字系统中。考虑一个数 N > 0 在进制 b ≥ 2 ,被写成如 ∑ki=0(aibi) 这样的标准记录。这里,通常对于所有的 i 有 0 ≤ ai < b 并且 ak 是非零的。当且仅当 对所有的 i 都有ai = ak-i 。 0 在任意进制中都写成 0 并且是一个回文数。

现在给你任意十进制整数 N 和进制 b ,你应该说明 N 是否是 b 进制下的一个回文数。


Input Specification (输入说明):

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

译:每个输入文件包含一个测试用例,每个用例包含两个正整数 Nb 是十进制下的数字 0<N≤109 2≤b≤109。数字间用空格分隔。


Output Specification (输出说明):

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak ak -1 ... a0 ". Notice that there must be no extra space at the end of output.

译:对于每个测试用例,在一行中输出,如果 Nb 数制下的回文数输出 Yes 否则输出 No。接下来的一行,用格式"ak ak -1 ... a0 " 输出 N 在 b 进制下的数字。注意 行末没有多与的空格。


Sample Input 1 (样例输入1):

27 2

Sample Output 1 (样例输出1):

Yes
1 1 0 1 1

Sample Input 2 (样例输入2):

121 5

Sample Output 2 (样例输出2):

No
4 4 1

The Idea:

涉及到回文数,首先将数字 N 转为 b 进制下的数字存入数组中,然后再根据题目意思 判断 ai = ak-i 。如果有不满足的,令标致为 false 并退出循环。最后根据 flag 的值输出 Yes or No ,再输出 b 进制下的 N .


The Codes:

#include<bits/stdc++.h>
using namespace std;
//string str = "";
int base[32] ; 
int main(){
	int n , b , t , cnt = 0 , flag = 1 ;
	cin >> n >> b ;
	while(n){
		base[cnt ++] = n % b ; // 取余
		n /= b ;
	}
	for(int i = 0 ; i < cnt ; i ++){
		if(base[i] != base[cnt - i - 1]){
			flag = 0 ;
			break ;
		}
	}
	printf((flag?"Yes\n":"No\n")); // 输出是否是一个回文数
	for(int i = cnt - 1 ; i >= 0 ; i --)
		printf("%d%c",base[i] , (i == 0 )?'\n':' '); 
	return 0;
}


上一篇:LeetCode 5. Longest Palindromic Substring


下一篇:1019 General Palindromic Number (20 分)