PAT (Advanced Level) Practice 1053 Path of Equal Weight (30 分) 凌宸1642

PAT (Advanced Level) Practice 1053 Path of Equal Weight (30 分) 凌宸1642

题目描述:

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

PAT (Advanced Level) Practice 1053 Path of Equal Weight (30 分) 凌宸1642

译:给定一棵根为 R 的非空树,并将权重 Wi 赋给每个树节点 Ti 。从 R 到 L 的路径的权值定义为从 R 到任意叶节点 L 的路径上所有节点权值的和。
现在给定任意一棵加权树,你应该找到所有的路径它们的权重都等于一个给定的数字。例如,让我们考虑如下图所示的树:对于每个节点,上面的数字是一个两位数的节点 ID,下面的数字是该节点的权值。假设给定的数字为 24,则存在4条具有相同给定权值的不同路径:{10 5 2 7}、{10 4 10}、{10 3 3 6 2}和{10 3 3 6 2},它们分别对应图中的红边。


Input Specification (输入说明):

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

译:每个输入文件包含一个测试用例。每一种情况都从一行开始,这一行包含0< N ≤ 100, 树中的节点数, M (<N),非叶节点数,0< S < 230,给定的权值。下一行包含 N 个正数,其中 Wi(<1000) 对应于树节点 Ti。然后是 M行,每一行的格式是:

ID K ID[1] ID[2]…ID [K]

其中 ID 是一个代表给定非叶节点的两位数,K 是它的子节点的数目,后面是它的子节点的一个两位数 ID 序列。为了简单起见,让我们将根 ID固定为 00。 N (1< N < 231) 。


Output Specification (输出说明):

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.

译:对于每个测试用例,按不增加的顺序打印所有权值为S的路径。每个路径占用一行,按顺序打印从根到叶的权重。所有的数字必须用一个空格隔开,在行尾没有多余的空格。
注:如果存在1 ≤ k< min {n,m},使Ai=Bi对于i=1,⋯,k,和Ak+1>Bk+1,则序列{A1,A2,⋯,An}大于序列{B1,B2,⋯,Bm}。 。


Sample Input (样例输入):

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output (样例输出):

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

The Codes:

#include<bits/stdc++.h>
using namespace std ;
#define MAX 110 
struct node{
	int weight ; // 权值 
	vector<int> child ; // 指针域,所有孩子结点 
}Node[MAX] ; 
bool cmp(int a , int b){
	return Node[a].weight > Node[b].weight ; // 将子结点按照 权值降序排列 
}
int n , m , s ;
int path[MAX] ;
void dfs(int index , int nowNode , int sumW){
	if(sumW > s) return ; //如果权值大于 s ,直接返回 
	if(sumW == s){
		if(Node[index].child.size() != 0) return ; // 有子结点,说明未到达叶子结点, 直接返回
		for(int i = 0 ; i < nowNode ; i ++){ // 此时 path 中已有一条完整的路径,输出 
			printf("%d%c" , Node[path[i]].weight , (i == nowNode - 1)?'\n':' ') ;
		} 
		return ;
	}
	for(int i = 0 ; i < Node[index].child.size() ; i ++){ // 对于当前结点的所有子结点 
		int ch = Node[index].child[i] ; // 获得当前结点的第 i 个子结点 
		path[nowNode] = ch ; // 将第 i 个子结点加入 path 中 
		dfs(ch , nowNode + 1 , sumW + Node[ch].weight) ; // 对变化后,再一次深搜 
	}
}
int main(){
	scanf("%d%d%d" , &n , &m , &s) ; // 输入 n ,m ,s 
	for(int i = 0 ; i < n ; i ++){ 
		scanf("%d" , &Node[i].weight) ; // 输入每个结点的权值 
	}
	int k , l  , t ; 
	for(int i = 0 ; i < m ; i ++){ // m 行输入 
		scanf("%d%d" , &k , &l) ; // 结点 k 以及其子结点个数 l 
		for(int j = 0 ; j < l ; j ++){
			scanf("%d" , &t) ; 
			Node[k].child.push_back(t) ; // 存储结点 k 的每一个子结点 
		}
		sort(Node[k].child.begin() , Node[k].child.end() , cmp ) ; // 将子结点按权值降序排列 
	}
	path[0] = 0 ; // 起点为 根结点 
	dfs(0 , 1 , Node[0].weight ) ; // dfs初始 
	return 0;
}


上一篇:1053最大数输出


下一篇:Django操作数据库查看内部sql语句方式