HDU 2035 人见人爱A^B 分类: ACM 2015-06-22 23:54 9人阅读 评论(0) 收藏

人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27711    Accepted Submission(s): 18946

Problem Description
求A^B的最后三位数表示的整数。

说明:A^B的含义是“A的B次方”
 
Input
输入数据包含多个测试实例,每个实例占一行,由两个正整

数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 
Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 
Sample Input
2 3
12 6
6789 10000
0 0
 
Sample Output
8
984
1
 
Author
lcy
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  1021 2034 1008 1108 1425
#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 115 int main()
{
int a,b;
while(~scanf("%d%d",&a,&b)&&(a+b))
{
int c=1;
while(b--)
{
c=(c*a)%1000;
}
printf("%d\n",c);
} return 0;
} //freopen("1.txt", "r", stdin);
//freopen("2.txt", "w", stdout);
//**************************************

版权声明:本文为博主原创文章,未经博主允许不得转载。

上一篇:maven 修改默认的JDK版本


下一篇:FastJson - 从HttpEntity到Json