POJ2393 Yogurt factory (贪心)

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 


Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 


Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

 

Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

 

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS: 
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units. 

题意

有一个奶酪工厂,给出这个工厂每天加工每个奶酪需要的价格,以及每天的需求量,另外,奶酪也可以存放在仓库里,给出每个奶酪存放一天需要的价格,问,这些生产任务全部完成,最少的花费是多少。

思路

如果当天生产比较省钱,那么就当天生产!而且假设以后的所有奶酪都在这天生产的!为何这样呢?因为题目给出的奶酪存放的需要的价格完全一样!哪天生产更廉价,就哪天生产,这就要求对每天进行编号了。这样才能进行定量计算和查找最优解。

代码如下

#include <stdio.h>
#include <string.h>
#define maxn 10002
int min(int a, int b)
{
    return a < b ? a : b;
}
int X[maxn],Y[maxn];
int main()
{
    int N, S, i, j;
    __int64 sum;//64位定义。不然过不了。
    while(scanf("%d%d",&N,&S)==2)
    {
        for(i=0;i<N;++i)
            scanf("%d%d",&X[i],&Y[i]);
        for(i=sum=0;i<N;++i)
        {
            sum+=X[i]*Y[i];
            if(i!=N-1)
                X[i+1]=min(X[i+1],X[i]+S);
        }
        printf("%I64d\n",sum);
    }
    return 0;
}

 

 

上一篇:WPF,ListView设置分组


下一篇:C++输入输出流运算符重载