1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10
​5
​​ ), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next
whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

自己没用链表,麻烦了

//Sharing
// suffix后缀 
#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
//找到父亲节点有两个的就可以了
vector<int> res1;
vector<int> res2;
int add1,add2,n;
vector<int> addr[100005];
int main()
{
 cin>>add1>>add2>>n;
 int add,nadd;
 char ch;
 for(int i = 0;i<n;i++)
 {
 	cin>>add>>ch>>nadd;
 	addr[add].push_back(nadd);
 }
 for(int i = add1;;)
 {
 	if(i==-1||addr[i].size() ==0)
	 {
	 res1.push_back(i);	
	 break;
	 }
 	res1.push_back(i);
 	i = addr[i][0];
 }
 for(int i = add2;;)
 {
 	if(i==-1||addr[i].size()==0)
	{
	 res2.push_back(i);	
	 break;
	}
 	res2.push_back(i);
 	if(addr[i].size()>1) i = addr[i][1];
 	else i = addr[i][0];
 }
 int i = res1.size()-1;
 int j = res2.size()-1;
 int ans;
 while(i>=0&&j>=0)
 {
 	if(res1[i]!=res2[j])
 	 break;
 	ans = res1[i];
 	i--;
 	j--;
 }
 if(ans!=-1)
 printf("%05d",ans);
 else
 printf("-1");
 return 0;
} 

链表写法:

#include <iostream>
using namespace std;
struct {
    char key;
    int next;
    bool flag;
}node[100010];
int main(){
    int d1,d2,n;
    cin>>d1>>d2>>n;
    for(int i=0;i<n;i++){
        int t1,t2;
        char ch;
        cin>>t1>>ch>>t2;
        node[t1]={ch,t2,false};
    }
    for(int i=d1;i!=-1;i=node[i].next) node[i].flag=true;
    for(int i=d2;i!=-1;i=node[i].next) {
        if(node[i].flag){
            printf("%05d",i);
            return 0;
        }
    }
    printf("-1");
    return 0;
}
上一篇:GDB调式工具学习笔记---单步执行和跟踪函数调用


下一篇:django.db.models.query.QuerySet格式的数据输出