1044 Shopping in Mars (25 point(s)) - C语言 PAT 甲级

1044 Shopping in Mars (25 point(s))

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.
If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤ 105), the total number of diamonds on the chain, and M (≤ 108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ⋯ DN (Di ≤ 103 for all i=1, ⋯, N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.
If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj > M with (Di + … + Dj − M) minimized. Again all the solutions must be printed in increasing order of i.
It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题目大意:

输入一个有 N 个元素的序列,求一段连续序列的和恰好等于期望值 M,如果找不到恰好等于的序列,就找到代价最小的序列(序列和必须大于等于 M 值);

输出所有可能的结果,每组序列的前后索引;

设计思路:
  • 维护一个窗口,窗口从头遍历到尾,并维护一个代价最小的期望值 max
    • if (sum < M),窗口右侧右移
    • else if (sum >= M),窗口左侧右移
      • if (sum < max),即维护的代价最小的值需要改变,此时结果需要重新记录
      • if (sum == M),符合当前代价最小的期望值,记录结果
  • 原始序列右侧可以加一个值为 0 的哨兵,因为窗口到达序列尾部,依旧需要移动进行判断
    • 例如 M 的值为 9,序列为三个元素,加一个哨兵 0
    • 1, 3, 9, 0;到达尾部 9 后,左侧需要继续移动判断
    • 1, 3, 5, 0;到达尾部 5 后,右侧依旧可以进入循环体判断
编译器:C (gcc)
#include <stdio.h>
#include <limits.h>

int main(void)
{
        int n, m, d[100001] = {0};
        int p[100000] = {0}, q[100000] = {0}, count = 0, max = INT_MAX;
        int sum = 0;
        int i, j;

        scanf("%d %d", &n, &m);
        for (i = 0; i < n; i++) {
                scanf("%d", &d[i]);
        }

        i = 0; j = 0;
        while (i < n && j <= n) {
                if (sum < m) {
                        sum += d[j];
                        j++;
                } else {
                        if (sum < max) {
                                max = sum;
                                count = 0;
                                p[count] = i + 1;
                                q[count] = j;
                                count++;
                        } else if (sum == max) {
                                p[count] = i + 1;
                                q[count] = j;
                                count++;
                        }
                        sum -= d[i];
                        i++;
                }
        }

        for (i = 0; i < count; i++) {
                printf("%d-%d\n", p[i], q[i]);
        }
        return 0;
}
上一篇:PAT Advanced 1044 Shopping in Mars (25) [⼆分查找]


下一篇:超慢速移动动画使用CSS3实现流畅效果