uva 348 - Optimal Array Multiplication Sequence



 Optimal Array Multiplication Sequence 

Given two arrays A and B, we can determine the array C = A B using the standard definition of matrix multiplication:

uva 348 - Optimal Array Multiplication Sequence

The number of columns in the A array must be the same as the number of rows in the B array. Notationally, let‘s say that rows(A) and columns(A) are the number of rows and columns, respectively, in the A array. The number of individual multiplications required to compute the entire C array (which will have the same number of rows as A and the same number of columns as B) is then rows(Acolumns(Bcolumns(A). For example, if Ais a uva 348 - Optimal Array Multiplication Sequence array, and B is a uva 348 - Optimal Array Multiplication Sequence array, it will take uva 348 - Optimal Array Multiplication Sequence , or 3000 multiplications to compute the C array.

To perform multiplication of more than two arrays we have a choice of how to proceed. For example, if XY, and Z are arrays, then to compute X Y Z we could either compute (X YZ or X (Y Z). Suppose X is a uva 348 - Optimal Array Multiplication Sequencearray, Y is a uva 348 - Optimal Array Multiplication Sequence array, and Z is a uva 348 - Optimal Array Multiplication Sequence array. Let‘s look at the number of multiplications required to compute the product using the two different sequences:

(X YZ

  • uva 348 - Optimal Array Multiplication Sequence multiplications to determine the product (X Y), a uva 348 - Optimal Array Multiplication Sequence array.
  • Then uva 348 - Optimal Array Multiplication Sequence multiplications to determine the final result.
  • Total multiplications: 4500.

X (Y Z)

  • uva 348 - Optimal Array Multiplication Sequence multiplications to determine the product (Y Z), a uva 348 - Optimal Array Multiplication Sequence array.
  • Then uva 348 - Optimal Array Multiplication Sequence multiplications to determine the final result.
  • Total multiplications: 8750.

Clearly we‘ll be able to compute (X YZ using fewer individual multiplications.

Given the size of each array in a sequence of arrays to be multiplied, you are to determine an optimal computational sequence. Optimality, for this problem, is relative to the number of individual multiplications required.

Input

For each array in the multiple sequences of arrays to be multiplied you will be given only the dimensions of the array. Each sequence will consist of an integer N which indicates the number of arrays to be multiplied, and then N pairs of integers, each pair giving the number of rows and columns in an array; the order in which the dimensions are given is the same as the order in which the arrays are to be multiplied. A value of zero for N indicates the end of the input. N will be no larger than 10.

Output

Assume the arrays are named uva 348 - Optimal Array Multiplication Sequence . Your output for each input case is to be a line containing a parenthesized expression clearly indicating the order in which the arrays are to be multiplied. Prefix the output for each case with the case number (they are sequentially numbered, starting with 1). Your output should strongly resemble that shown in the samples shown below. If, by chance, there are multiple correct sequences, any of these will be accepted as a valid answer.

Sample Input

3
1 5
5 20
20 1
3
5 10
10 20
20 35
6
30 35
35 15
15 5
5 10
10 20
20 25
0

Sample Output

Case 1: (A1 x (A2 x A3))
Case 2: ((A1 x A2) x A3)
Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))



题目大意:可以任意结合律,求矩阵乘法的最大值


可以用记忆优化DP,划分子问题,DP(L,R) ,记录 【L,R】区间最大值。

DP(l,r)=max(DP(l,k)+DP(k,r)+dp(i,k)+dp(k,j)+a[i][0]*a[k][0]*a[j-1][1])


#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

const int maxn=30;
int n,path[maxn][maxn];
long long d[maxn][maxn],a[maxn][10];

void out(int l,int r){
    int mid=path[l][r];
    if(mid>0){
        cout<<"(";
        out(l,mid);
        cout<<" x ";
        out(mid,r);
        cout<<")";
    }
    if(l+1==r) cout<<"A"<<l+1;
    if(l+2==r) cout<<"(A"<<l+1<<" x A"<<l+2<<")";
}

long long dp(int i,int j){
    if(d[i][j]!=-1) return d[i][j];
    if(i+1==j) return d[i][j]=0;
    if(i+2==j) return d[i][j]=a[i][0]*a[i+1][0]*a[i+1][1];
    int pos=i+1;
    long long ans=1e17;
    for(int k=i+1;k<j;k++){
        long long tmp=dp(i,k)+dp(k,j)+a[i][0]*a[k][0]*a[j-1][1];
        if(tmp<ans){
            ans=tmp;
            pos=k;
        }
    }
    path[i][j]=pos;
    return d[i][j]=ans;
}

int main(){
    int casen=0;
    while(cin>>n && n>0){
        for(int i=0;i<=n;i++){
            for(int j=0;j<=n;j++){
                d[i][j]=-1;
                path[i][j]=-1;
            }
        }
        for(int i=0;i<n;i++) cin>>a[i][0]>>a[i][1];
        cout<<"Case "<<++casen<<": ";
        dp(0,n);
        out(0,n);
        cout<<endl;
    }
    return 0;
}


uva 348 - Optimal Array Multiplication Sequence

上一篇:HUST 1352 求重复次数不小于k的子串的个数。


下一篇:【经典】servlet中常见的问题与解答