《程序设计基础》 第三章 分支结构 7-16 统计英文字母和数字字符[2] (15 分)

本题要求编写程序,输入N个字符,统计其中英文字母、数字字符和其他字符的个数。

输入格式:

输入在第一行中给出正整数N,第二行输入N个字符,最后一个回车表示输入结束,不算在内。

输出格式:

在一行内按照

letter = 英文字母个数, digit = 数字字符个数, other = 其他字符个数

的格式输出。请注意,等号的左右各有一个空格,逗号后有一个空格。

输入样例:

在这里给出一组输入。例如:

10
aZ &
09 Az

结尾无空行

输出样例:

在这里给出相应的输出。例如:

letter = 4, digit = 2, other = 4

结尾无空行

#include <stdio.h>
int main()
{
	int letter, blank, digit, other, n, i;
	char ch; 
	letter=blank=digit=other=0;
	scanf("%d",&n);
	getchar();
	for(i=1; i<=n; i++){
	ch=getchar();
	if((ch>='a'&&ch<='z')||(ch>='A'&&ch<='Z')){letter++; 
	}
        else{if(ch>='0'&&ch<='9'){digit++;
	}
        else{if(ch==' '||ch=='\n'){blank++;
	}
        else{other++;
	}
	}
	}
    }
	printf("letter = %d, digit = %d, other = %d",letter,digit,other+blank);
	return 0;
}

上一篇:18.os模块获取url后缀


下一篇:NSNull, Nil, nil, NULL区别(OC)