UOJ #56.线段树区间加和乘


【题目描述】:

如题,已知一个数列,你需要进行下面两种操作:

1.将某区间每一个数加上x

2.将某区间每一个数乘上x

3.求出某区间每一个数的和
【输入描述】:

第一行包含三个整数N、M、P,分别表示该数列数字的个数、操作的总个数和模数。

第二行包含N个用空格分隔的整数,其中第i个数字表示数列第i项的初始值。

接下来M行每行包含3或4个整数,表示一个操作,具体如下:

操作1: 格式:1 x y k 含义:将区间[x,y]内每个数乘上k(>0)

操作2: 格式:2 x y k 含义:将区间[x,y]内每个数加上k(>0)

操作3: 格式:3 x y 含义:输出区间[x,y]内每个数的和对P取模所得的结果
【输出描述】:

输出包含若干行整数,即为所有操作3的结果。
【样例输入】:

5 5 38
1 5 4 2 3
2 1 4 1
3 2 5
1 2 4 2
2 3 5 5
3 1 4

【样例输出】:

17
2

【时间限制、数据范围及描述】:

时间:1s 空间128M

对于30%的数据:N<=10,M<=10

对于70%的数据:N<=1,000,M<=10,000

对于100%的数据:N<=100,000,M<=100,000

Code:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<ctime>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<map>
using namespace std;
const int N=2000005;
long long p,k,c[N],sum[N],addv[N],mulv[N];
int n,m,i,f,x,y;
void build(int o,int l,int r){
    addv[o]=0;
    mulv[o]=1;
    if(l==r){
        sum[o]=c[l];
    }
    else{
        int mid=(l+r)>>1;
        int lson=o<<1;
        int rson=lson|1;
        build(lson,l,mid);
        build(rson,mid+1,r);
        sum[o]=(sum[lson]+sum[rson])%p;
    }
}    
void push_down(int o,int l,int r,int mid,int lson,int rson){
    mulv[lson]=(mulv[lson]*mulv[o])%p;
    mulv[rson]=(mulv[rson]*mulv[o])%p;
    addv[lson]=(addv[lson]*mulv[o])%p;
    addv[rson]=(addv[rson]*mulv[o])%p;
    sum[lson]=(sum[lson]*mulv[o])%p;
    sum[rson]=(sum[rson]*mulv[o])%p;
    mulv[o]=1;
    addv[lson]=(addv[lson]+addv[o])%p;
    addv[rson]=(addv[rson]+addv[o])%p;
    sum[lson]=(sum[lson]+(mid-l+1)*addv[o])%p;
    sum[rson]=(sum[rson]+(r-mid)*addv[o])%p;
    addv[o]=0;
}
void addall(int o,int l,int r,int a,int b,int x){
    if(l>=a&&r<=b){
        addv[o]=(addv[o]+x)%p;
        sum[o]=(sum[o]+(r-l+1)*x)%p;
        return;
    }
    else{
        int mid=(l+r)>>1;
        int lson=o<<1;
        int rson=lson|1;
        if(mulv[o]!=1||addv[o]){
            push_down(o,l,r,mid,lson,rson);
        }
        if(a<=mid){
            addall(lson,l,mid,a,b,x);
        }
        if(b>mid){
            addall(rson,mid+1,r,a,b,x);
        }
        sum[o]=(sum[lson]+sum[rson])%p;
    }
}
void mulall(int o,int l,int r,int a,int b,int x){
    if(l>=a&&r<=b){
        mulv[o]=(mulv[o]*x)%p;
        addv[o]=(addv[o]*x)%p;
        sum[o]=(sum[o]*x)%p;
        return;
    }
    else{
        int mid=(l+r)>>1;
        int lson=o<<1;
        int rson=lson|1;
        if(mulv[o]!=1||addv[o]){
            push_down(o,l,r,mid,lson,rson);
        }
        if(a<=mid){
            mulall(lson,l,mid,a,b,x);
        }
        if(b>mid){
            mulall(rson,mid+1,r,a,b,x);
        }
        sum[o]=(sum[lson]+sum[rson])%p;
    }
}
long long query(int o,int l,int r,int a,int b){
    if(l>=a&&r<=b){
        return sum[o]%p;
    }
    else{
        int mid=(l+r)>>1;
        int lson=o<<1;
        int rson=lson|1;
        long long ans=0;
        if(mulv[o]!=1||addv[o]){
            push_down(o,l,r,mid,lson,rson);
        }
        if(a<=mid){
            ans+=query(lson,l,mid,a,b);
        }
        if(b>mid){
            ans+=query(rson,mid+1,r,a,b);
        }
        return ans%p;
    }
}
int main(){
    scanf("%d%d%lld",&n,&m,&p);
    for(i=1;i<=n;i++){
        scanf("%lld",&c[i]);
    }
    build(1,1,n);
    for(i=1;i<=m;i++){
        scanf("%d",&f);
        switch(f){
            case 1:{
                scanf("%d%d%lld",&x,&y,&k);
                mulall(1,1,n,x,y,k);
                break;
            }
            case 2:{
                scanf("%d%d%lld",&x,&y,&k);
                addall(1,1,n,x,y,k);
                break;
            }
            case 3:{
                scanf("%d%d",&x,&y);
                printf("%lld\n",query(1,1,n,x,y));
                break;
            }    
        }
    }
    return 0;
}
上一篇:【模板】Splay(luogu)


下一篇:洛谷 P3372 【模板】线段树 1