数据结构 10-排序5 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained
 

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]
 

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
 

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

 

需要注意的地方

1. id是从1开始的 1到N

2.需要区分没有提交过的题目的成绩(-2) 和 提交了但是编译没通过(-1) 和 提交并通过但是得0分的成绩(0)

3. 在2中 -1 和 0 的成绩是需要输出题目得分 0 的 , 如果总分为0 排行榜也要显示成绩 ,如果是(-2)没有提交过 显示 '-'

4.可以用一个valid参数表示成绩是否有效,既 是否提交过

 

#include <iostream>
#include <vector>
#include <algorithm>
#include <iomanip>using namespace std;
class student{
public:
    int id;
    int FSN{0};//fullScourNum
    int totalScour{0};
    bool valid{false};
    vector<int> scour;
    student()=default;
    student(int i,int qNum):id{i},scour{vector<int>(qNum,-2)}{}
    void setGrade(int n,int s){
        if(s!=-1&&!valid){//成绩有效
            valid=true;
        }
        if(s==-1){
            s=0;
        }
        scour[n-1]=s;
    }
    int getTotalScour(){
        int ts{0};
        for(int i=0;i<scour.size();i++){
            if(scour[i]!=-2){
                ts+=scour[i];
            }
        }
        return ts;
    }
    void printStatu(){
        printf("%05d",id);
        printf(" %d",totalScour);
        for(int i=0;i<scour.size();i++){
            if(scour[i]!=-2){
                printf(" %d",scour[i]);
            }else{
                printf(" -");
            }
        }
        printf("\n");
    }
};

bool compare(student* l,student* r){
    if(l->totalScour==r->totalScour&&l->FSN==r->FSN){
       return l->id< r->id;
    }else if(l->totalScour==r->totalScour&&l->FSN!=r->FSN){
        return l->FSN > r->FSN;
    }else {
        return l->totalScour>r->totalScour;
    }
}

int main(){
    int n,k,m;
    int id,qn,s,temp;
    cin >> n >> k >> m;
    vector<student*> students;
    vector<int> FSofQ(k);
    for(int i=0;i<n;i++){
        students.push_back(new student{i+1,k});
    }
    for(int i=0;i<k;i++){
        cin >> temp;
        FSofQ[i]=temp;
    }
    for(int i=0;i<m;i++){
        cin >> id >> qn >> s;
        if(s>=-1&&s<=FSofQ[qn-1]&& s > students[id-1]->scour[qn-1]){//成绩合法
            students[id-1]->setGrade(qn, s);
            if(FSofQ[qn-1]==s&&FSofQ[qn-1]){//取得一题满分 满分不为0
                students[id-1]->FSN++;
            }
        }
    }
    for(int i=0;i<students.size();i++){
        if(students[i]->valid){
            students[i]->totalScour=students[i]->getTotalScour();
        }else{
            students[i]->totalScour=-1;
        }
        
    }
    
    sort(students.begin(), students.end(), compare);
    int rank=1;
    for(int i=0;i<students.size();i++){
        if(i!=0&&students[i]->totalScour!=students[i-1]->totalScour&&students[i]->valid){
            rank=i+1;
        }
        if(students[i]->valid){
            cout << rank<<" ";
            students[i]->printStatu();
        }
    }
    return 0;
}

 

上一篇:MapReduce 编程模型


下一篇:mysql数据库学习(3)--SQL语句增删改查