PAT A1143 Lowest Common Ancestor (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where Xis A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
 
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <map>
#include <vector>
#include <set>
using namespace std;
const int maxn=10010;
int n,m,k;
int inorder[maxn],preorder[maxn];
struct node{
    int data;
    node* left;
    node* right;
};
node* create(int prel,int prer,int inl,int inr){
    if(prel>prer){
        return NULL;
    }
    node* root=new node;
    root->data=preorder[prel];
    int k;
    for(k=inl;k<=inr;k++){
        if(inorder[k]==preorder[prel]){
            break;
        }
    }
    int numleft=k-inl;
    root->left = create(prel+1,prel+numleft,inl,k-1);
    root->right = create(prel+numleft+1,prer,k+1,inr);
    return root;
}
bool findnode(int x){
    for(int i=0;i<m;i++){
        if(preorder[i]==x) return true;
    }
    return false;
}
node* lca(node* root,int x1,int x2){
    if(root==NULL)return NULL;
    if(root->data==x1 || root->data==x2) return root;
    node* left = lca(root->left,x1,x2);
    node* right = lca(root->right,x1,x2);
    if(left && right) return root;
    else if(left==NULL) return right;
    else return left;
}
int main(){
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;i++){
        int c1;
        scanf("%d",&c1);
        preorder[i]=c1;
        inorder[i]=c1;
    }
    sort(inorder,inorder+m);
    node *root=create(0,m-1,0,m-1);
    for(int i=0;i<n;i++){
        int x1,x2;
        scanf("%d %d",&x1,&x2);
        if(!findnode(x1) && !findnode(x2)){
            printf("ERROR: %d and %d are not found.\n",x1,x2);
        }
        else if(!findnode(x1)) printf("ERROR: %d is not found.\n",x1);
        else if(!findnode(x2)) printf("ERROR: %d is not found.\n",x2);
        else{
            node* res = lca(root,x1,x2);
            if(res->data == x1) printf("%d is an ancestor of %d.\n",x1,x2);
            else if(res->data == x2) printf("%d is an ancestor of %d.\n",x2,x1);
            else printf("LCA of %d and %d is %d.\n",x1,x2,res->data);
        }
    }
}

注意点:这题和上一道1151基本一样,感觉是中间隔一次考试就会出现类似题目,不同的就是这个是给出二叉搜索树和他的先序遍历,而二叉搜索树的中序遍历其实就是对先序遍历排序,然后题目就一样了

上一篇:LeetCode 236 二叉树的最近公共祖先 Lowest Common Ancestor of a Binary Tree Python


下一篇:[P4782]2-SAT问题