hdu1712分组背包模板

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9327    Accepted Submission(s): 5118


 

Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

 

 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

 

 

Sample Input


 

2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0

 

 

Sample Output


 

3 4 6

 

 

Source

HDU 2007-Spring Programming Contest

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2159 3033 1171 2844 2415 

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define maxn 105
#define maxm 105
using namespace std;
int n,m;
int a[maxn][maxm];
int dp[maxm];
int main()
{
    while(~scanf("%d%d",&n,&m))
    {if(n==0&&m==0)
    break;
    memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
            scanf("%d",&a[i][j]);
            for(int i=1;i<=n;i++)
            for(int j=m;j>=0;j--)
            for(int k=1;k<=j;k++)
            {
                dp[j]=max(dp[j],dp[j-k]+a[i][k]);

            }
            printf("%d\n",dp[m]);
    }
    return 0;
}

 

上一篇:Linux文件目录


下一篇:MySQL(二)