2020 BIT冬训-二分三分快速幂矩阵 A - Expanding Rods POJ - 1905

Problem Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 2020 BIT冬训-二分三分快速幂矩阵 A - Expanding Rods POJ - 1905

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000
这题的思路是二分法寻找答案。二分高度h,使得计算出的l

且由于l’的超过长度不超过原来的一半。故二分区间为0~l/2即可。

不断与题目要求的逼近。
计算公式如下:
2020 BIT冬训-二分三分快速幂矩阵 A - Expanding Rods POJ - 1905

 

 

 AC代码如下:

#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
double le,n,c,lans,ltemp,a,l,r,mid,re;
int main(){
    while(scanf("%lf%lf%lf",&le,&n,&c)&&le>=0&&n>=0&&c>=0){
        lans=(1+n*c)*le;
        l=0,r=le/2;
        while(r-l>1e-4){
            mid=(l+r)/2;
            re=(mid*mid+le*le/4)/2/mid;
            a=asin(le/2/re);
            ltemp=2*a*re;
            if(ltemp<lans)
                l=mid;
            else
                r=mid;
        }
        printf("%.3f\n",l);
    }    
}

 



上一篇:Spring01-简介


下一篇:用rod获取百度搜索结果的例子