PAT A1028 List Sorting (25分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805468327690240

题目描述
Excel can sort records according to any column. Now you are supposed to imitate this function.

输入
Each input file contains one test case. For each case, the first line contains two integers N (≤10^​5​​ ) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

输出
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

样例输入
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

样例输出
000001 Zoe 60
000007 James 85
000010 Amy 90

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct student{
	int id;
	char name[10];
	int grade;
}stu[100010];

bool cmp1(student a, student b) {
	return a.id < b.id;
}

bool cmp2(student a, student b) {
	if(strcmp(a.name, b.name) != 0)
		return strcmp(a.name, b.name) < 0;
	else
		return a.id < b.id;
}

bool cmp3(student a, student b) {
	if(a.grade != b.grade)
		return a.grade < b.grade;
	else
		return a.id < b.id;
}

int main() {
	int n, c;
	scanf("%d%d", &n, &c);
	for(int i = 0; i < n; i++)
		scanf("%d %s %d", &stu[i].id, stu[i].name, &stu[i].grade);
	if(c == 1)	sort(stu, stu + n, cmp1);
	else if(c == 2)	sort(stu, stu + n, cmp2);
	else if(c == 3)	sort(stu, stu + n, cmp3);
	for(int i = 0; i < n; i++)
		printf("%06d %s %d\n", stu[i].id, stu[i].name, stu[i].grade);	
	return 0;
}

上一篇:1028 List Sorting (25分)


下一篇:java-如何在不使用比较器和比较器接口的情况下对地图进行排序?如何编写自定义排序?