Fibonacci Again

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

题意及分析:判断根据给定公式得到的第n个数是不是3的倍数。根据题意,因为(a+b)%3==a%3+b%3,所以我们直接把每次相加结果对三取余再保存就行了。

#include<iostream>
#include<cmath>
using namespace std;
int a[1000000];
int main()
{
    int n;
    a[0] = 7%3;
    a[1] = 11%3;
    for(int i = 2; i < 1000000; i++)
    {
        a[i] = (a[i-1] + a[i-2])%3;
    }
    while(cin>>n)
    {
        if(a[n]==0)cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }


    return 0;
}

 

上一篇:Java编译时错误:A JNI error has occurred, please check your installation and try again


下一篇:CF 578D LCS Again 简要题解