1134 Vertex Cover-PAT甲级

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

判断每条边中至少一个点是否在给出的集合中出现过,建立一个set,找每条边的点即可

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=10010;
struct Edge{
	int u,v;
}edge[N];
int n,m,k;
int main(){
	cin>>n>>m;
	for(int i=1;i<=m;i++){
		cin>>edge[i].u>>edge[i].v;
	}
	cin>>k;
	for(int i=1;i<=k;i++){
		int num;
		cin>>num;
		set<int>st;
		for(int j=1;j<=num;j++){
			int x;
			cin>>x;
			st.insert(x);
		}
		int flag=1;
		for(int j=1;j<=m;j++){
			if(st.find(edge[j].u)==st.end()&&st.find(edge[j].v)==st.end()){
				flag=0;
				break;
			}		
		}
		if(flag){
			cout<<"Yes"<<endl;
		}else{
			cout<<"No"<<endl;
		}
	}
	return 0;
}

 

上一篇:社交网络图中结点的“重要性”计算 (30 分) Java解法


下一篇:寻找最小矩形边框--OpenCv