信息学奥赛一本通(1140:验证子串)

1140:验证子串


时间限制: 1000 ms         内存限制: 65536 KB
提交数: 22557     通过数: 10919

【题目描述】

输入两个字符串,验证其中一个串是否为另一个串的子串。

【输入】

输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。

【输出】

若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)

否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)

否则,输出 No substring。

【输入样例】

abc
dddncabca

【输出样例】

abc is substring of dddncabca

【参考代码】

C代码:

#include <stdio.h>
#include <string.h>
#define N 210
char s1[N],s2[N];
int main()
{
	gets(s1);
	gets(s2);
	if(strstr(s1,s2)!=NULL)
	{
		printf("%s is substring of %s\n",s2,s1);
	}
    else if(strstr(s2,s1)!=NULL)
  	{
		printf("%s is substring of %s\n",s1,s2);
   	}
   	else
   	{
   		printf("No substring\n");
	}
	return 0;
}

C++代码:

#include <iostream>
#include <string>
using namespace std;
int main()
{
    string a,b;    
    cin >> a >> b;
    if(a.find(b)!=-1)
    	cout << b << " is substring of " << a;
    else if(b.find(a)!=-1)
    	cout << a << " is substring of " << b;
    else
    	cout << "No substring";
	return 0;
}

http://ybt.ssoier.cn:8088/problem_show.php?pid=1140

 

上一篇:X12 830和862报文的区别


下一篇:1140 1141 1142 1143模拟练习 (谜之压轴题)