ACM题目 1083: Hello, world!

题目描述:

This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.

输入:

The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.

输出:

Output the corresponding message. Note there is NOT a newline character in the end of output.

样例输入:

72 101 108 108 111 44
32 119 111 114 108 100 33

样例输出:

Hello, world!

思路:

将所有数字存放到一个数组中

然后对数组中每一个数字取整数输出

代码:

#include<stdio.h>
int main()
{
    char c;
    int a[100],i=0;
    while((scanf("%d",&a[i]))!=EOF)
    {
        i++;
    }
    for(int j=0;j<i;j++)
        printf("%c",a[j]);
    return 0;
}

  

 

上一篇:1083 List Grades (25 分)


下一篇:Day59: [PAT甲级] 1083 List Grades (25分)