2130 Problem D More is better

问题 D: More is better

时间限制: 1 Sec  内存限制: 128 MB
提交: 340  解决: 123
[提交][状态][讨论版][命题人:外部导入]

题目描述

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入

3
1 3
1 5
2 5
4
3 2
3 4
1 6
2 6

样例输出

4
5
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN = 1e7;
int f[MAXN], num[MAXN];

int seek(int x) {
	if (x == f[x]) return x;
	else {
		int FX = seek(f[x]);
		f[x] = FX;
		return FX;
	}
}
int main() {
	int n, a, b;
	while (cin >> n) {
		for (int i = 1; i <= 10000000; i++) {
			f[i] = i;
			num[i] = 1;
		}
		int Max = 1;
		for (int i = 0; i < n; i++) {
			cin >> a >> b;
			int FA = seek(a), FB = seek(b);
			if (FA != FB) {
				f[FB] = FA;
				num[FA] += num[FB];
				Max = max(Max, num[FA]);
			}
		}
		cout << Max << endl;
	}
	return 0;
}

 

上一篇:二.Vue2.5开发去哪儿网app城市列表页③——Better-scroll的使用和字母表布局


下一篇:Flutter Dart语言中DateTime的使用