哈希-Snowflake Snow Snowflakes 分类: POJ 哈希 2015-08-06 20:53 2人阅读 评论(0) 收藏

Snowflake Snow Snowflakes

Time Limit: 4000MS Memory Limit: 65536K

Total Submissions: 34762 Accepted: 9126

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:

No two snowflakes are alike.

If there is a pair of possibly identical snow akes, your program should print the message:

Twin snowflakes found.

Sample Input

2

1 2 3 4 5 6

4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source

CCC 2007

题意:给你雪花的六个臂的长度(以其中的任意一个臂为起点,顺时针或者逆时针给出),让你判断是不是有两片雪花相同;

方法:如果是相同的雪花,则六个臂长之和必定相等,这就需要哈希,因为六个臂的数值比较大,所以采用哈希链表的形式.比较两个雪花是不是相同,可以固定一个雪花,以另一个雪花的六个臂分别为起点进行顺时针和逆时针的比较,就可以解决同构的问题(开始用STL写的,不知哪里错了,一怒之下手写链表)

#include <map>
#include <set>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-9
#define LL long long
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CRR fclose(stdin)
#define CWW fclose(stdout)
#define RR freopen("input.txt","r",stdin)
#define WW freopen("output.txt","w",stdout) const int MAX = 1e6+10; const int Mod = 100007; struct node
{
int a[6];
node *next;
}; struct Point
{
int num;
node *next;
} Head[Mod]; bool cmp(node *a,node *b)
{
for(int i=0; i<6; i++)//比较
{
if(a->a[0]==b->a[i]&&a->a[1]==b->a[(i+1)%6]&&a->a[2]==b->a[(i+2)%6]
&&a->a[3]==b->a[(i+3)%6]&&a->a[4]==b->a[(i+4)%6]&&a->a[5]==b->a[(i+5)%6])
{
return true;
}
if(a->a[0]==b->a[i]&&a->a[1]==b->a[(i+5)%6]&&a->a[2]==b->a[(i+4)%6]
&&a->a[3]==b->a[(i+3)%6]&&a->a[4]==b->a[(i+2)%6]&&a->a[5]==b->a[(i+1)%6])
{
return true;
}
}
return false;
} int main()
{
int n;
node *p,*q;
while(~scanf("%d",&n))
{
for(int i=0; i<Mod; i++)
{
Head[i].num=0;
Head[i].next=NULL;
}
for(int i=0; i<n; i++)//哈希链表
{
p=new node;
p->next=NULL;
int sum=0;
for(int j=0; j<6; j++)
{
scanf("%d",&p->a[j]);
sum+=p->a[j];
}
sum%=Mod;
p->next=Head[sum].next;
Head[sum].next=p;
Head[sum].num++;
}
bool flag=false;
for(int i=0; i<Mod; i++)
{
if(Head[i].num<=1)
{
continue;
}
for(p=Head[i].next; p!=NULL; p=p->next)
{
for(q=p->next; q!=NULL; q=q->next)
{
if(cmp(q,p))
{
flag=true;
break;
}
}
if(flag)
{
break;
}
}
if(flag)
{
break;
}
}
if(flag)
{
printf("Twin snowflakes found.\n");
}
else
{
printf("No two snowflakes are alike.\n");
}
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

上一篇:HDU 2121 Ice_cream’s world II 不定根最小树形图


下一篇:实战:使用SVN+apache搭建一个版本控制服务器