1031 Hello World for U (20 分) java 题解

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题目大意:

给定一串字符串,使其按U字形输出。

解题思路:

按照题给公式计算出行数以及需要添加的空格数即可。

java代码:

import java.io.*;

public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String s = br.readLine();
		int len = s.length();
		int n = (len + 2) / 3 - 1;
		int space = len - 2 * (n + 1); 
		StringBuilder builder = new StringBuilder();
		for(int i = 0; i < n;i++) {
			builder.append(s.charAt(i));
			for(int j = 0; j < space;j++) {
				builder.append(" ");
			}
			builder.append(s.charAt(len - 1 - i) + "\n");
		}
		for(int i = n;i < n + space + 2;i++) {
			builder.append(s.charAt(i));
		}
		System.out.print(builder.toString());
	}
}

PAT提交截图:

1031 Hello World for U (20 分) java 题解

上一篇:electron-vue 报错 Unresolved node modules: bufferutil, utf-8-validate, canvas


下一篇:Asp.net Core3.1使用Autofac