hdu1002大数相加

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 313689 Accepted Submission(s):
60742

Problem Description
I have a very simple problem for you. Given two
integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer
T(1<=T<=20) which means the number of test cases. Then T lines follow,
each line consists of two positive integers, A and B. Notice that the integers
are very large, that means you should not process them by using 32-bit integer.
You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The
first line is "Case #:", # means the number of the test case. The second line is
the an equation "A + B = Sum", Sum means the result of A + B. Note there are
some spaces int the equation. Output a blank line between two test
cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
--------------------------------------------------

import java.math.BigInteger;
import java.text.Bidi;
import java.util.Scanner;
public class Main1002 {
public static void main(String[] args) {
Scanner cin=new Scanner(System.in);
while(cin.hasNext()){
int n=cin.nextInt();
int t=0;
while(n-->0){
BigInteger b=cin.nextBigInteger();
BigInteger c=cin.nextBigInteger();
BigInteger d=new BigInteger("0");
d=b.add( c);
System.out.println("Case"+" "+(++t)+":");
System.out.println(b+" "+"+"+" "+c+" "+"="+" "+d);
if(n!=0)
System.out.println();
}
}

}

}

感觉用java 做大数相加的这个题好简单呀

上一篇:ros安装-orbslam编译-跑ros例程 踩坑指南


下一篇:A+B and A*B problem 大数相加 相乘 模拟