Problem A: Artificial Intelligence?

Description

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which
power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.

Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number.

Directly before the unit (A, V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept '=' RealNumber [Prefix] Unit

Concept ::= 'P' | 'U' | 'I'

Prefix ::= 'm' | 'k' | 'M'

Unit ::= 'W' | 'V' | 'A'

Additional assertions:

The equal sign (`=') will never occur in an other context than within a data field.

There is no whitespace (tabs,blanks) inside a data field.

Either P and U, P and I, or U and I will be given.

Output

For each test case, print three lines:

a line saying ``Problem #k" where k is the number of the test case

a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output

a blank line

Sample Input

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output

Problem #1
P=900.00W Problem #2
I=0.45A Problem #3
U=1250000.00V

HINT

#include<stdio.h>
#include<string.h>
int main()
{
int n,t,i,k=1,x;
double P,U,I,b;
char a[1000];
scanf("%d",&n);
getchar();
x=n;
while(n--)
{
P=0;
U=0;
I=0;
gets(a);
t=strlen(a); for(i=0;i<t;i++)
{
b=1;
if(a[i]=='U'&&a[i+1]=='=')
{
i=i+2;
while(a[i]>='0'&&a[i]<='9')
{
U=U*10+a[i]-'0';
i++;
}
if(a[i]=='.')
{
i++;
while(a[i]>='0'&&a[i]<='9')
{
b=b*0.1;
U=U+b*(a[i]-'0');
i++;
}
}
if(a[i]=='m')
{
U=U/1000;
i++;
}
else if(a[i]=='k')
{
U=U*1000;
i++;
}
else if(a[i]=='M')
{
U=U*1000000;
i++;
}
}
else if(a[i]=='P'&&a[i+1]=='=')
{
i=i+2;
while(a[i]>='0'&&a[i]<='9')
{
P=P*10+a[i]-'0';
i++;
}
if(a[i]=='.')
{
i++;
while(a[i]>='0'&&a[i]<='9')
{
b=b*0.1;
P=P+b*(a[i]-'0');
i++;
}
}
if(a[i]=='m')
{
P=P/1000;
i++;
}
else if(a[i]=='k')
{
P=P*1000;
i++;
}
else if(a[i]=='M')
{
P=P*1000000;
i++;
} }
else if(a[i]=='I'&&a[i+1]=='=')
{
i=i+2;
while(a[i]>='0'&&a[i]<='9')
{
I=I*10+a[i]-'0';
i++;
}
if(a[i]=='.')
{
i++;
while(a[i]>='0'&&a[i]<='9')
{
b=b*0.1;
I=I+b*(a[i]-'0');
i++;
}
}
if(a[i]=='m')
{
I=I/1000;
i++;
}
else if(a[i]=='k')
{
I=I*1000;
i++;
}
else if(a[i]=='M')
{
I=I*1000000;
i++;
}
}
}
printf("Problem #%d\n",k);
if(P>0&&I>0)
printf("U=%.2lfV\n",P/I);
else if(P>0&&U>0)
printf("I=%.2lfA\n",P/U);
else if(U>0&&I>0)
printf("P=%.2lfW\n",U*I);
if(k!=x)
printf("\n");
k++;
}
return 0;
}

上一篇:JavaScript 字符串实用常用操作


下一篇:解决Ckeditor编辑器不显示html实体,自动过滤html的问题