Codevs 1083 Cantor表

 时间限制: 1 s   空间限制: 128000 KB   题目等级 : 白银 Silver
题目描述 Description

现代数学的著名证明之一是Georg Cantor证明了有理数是可枚举的。他是用下面这一张表来证明这一命题的: 1/1 1/2 1/3 1/4 1/5 … 2/1 2/2 2/3 2/4 … 3/1 3/2 3/3 … 4/1 4/2 … 5/1 … … 我们以Z字形给上表的每一项编号。第一项是1/1,然后是1/2,2/1,3/1,2/2,…

Codevs 1083   Cantor表

输入描述 Input Description

整数N(1≤N≤10000000)

输出描述 Output Description

表中的第N项

样例输入 Sample Input

7

样例输出 Sample Output

1/4

数据范围及提示 Data Size & Hint

见描述

 #include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int map[][],n;
int main()
{
cin>>n;
int s=0,t,k=1;
while(s<n)
{
s+=k;
k++;
}
t=s-n+1;
if((k-1)%2==0)
printf("%d/%d",k-t,t);
else
printf("%d/%d",t,k-t); return 0;
}

思路:斜着一列列的看~,自己慢慢想去吧

上一篇:mysql 的快速入门


下一篇:ASP.NET Core 中的 ORM 之 Dapper