PTA(Advanced Level)1037.Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
思路
  • 简单来说题意就是从ab两个数字集合各取1个数字,最后看能算出来的最大和是多少
  • 很容易想到的贪心策略是:①正数从大到小乘;②负数从小到大乘
代码
#include<bits/stdc++.h>
using namespace std;
int a[100010];
int b[100010];


int main()
{
    int nc,np;
    scanf("%d", &nc);
    for(int i=0;i<nc;i++)   scanf("%d", &a[i]);
    scanf("%d", &np);
    for(int i=0;i<np;i++)   scanf("%d", &b[i]);
    sort(a, a+nc);
    sort(b, b+np);

    int p1 = 0;
    int p2 = 0;
    long long  ans = 0;

    while(p1 < nc && p1 < np && a[p1] < 0 && b[p1] < 0)    //处理负数和负数相乘的情况
    {
        ans += a[p1] * b[p1];
        p1++;
    }
    p1 = nc - 1;
    p2 = np - 1;
    while(p1 >= 0 && p2 >= 0 && a[p1] > 0 && b[p2] > 0)
    {
        ans += a[p1] * b[p2];
        p1--;
        p2--;
    }

    printf("%lld\n", ans);
    return 0;
}

引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805451374313472

上一篇:1037 Magic Coupon (25 分)


下一篇:Dx bad class file magic (cafebabe) or version (0033.0000) 导致 NoClassDefFoundError 的问题