迷宫问题 POJ - 3984

题目:

定义一个二维数组: 


int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。 Output 左上角到右下角的最短路径,格式如样例所示。 Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
思路:迷宫问题一般采用BFS()能得到最短路径。本题是一道模板题,鉴于处于起步阶段,写的比较完整(繁琐)。
题解:
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
char maze[5][5];
int vis[5][5];
int dx[4]={-1,0,1,0};
int dy[4]={0,1,0,-1};
struct Road
{
    int x,y;
}pre[6][6];//记录路径 
Road start;//起点 
Road ed;//终点,注意不能用 end 
bool check(int i,int j)
{
    if(i>=0&&i<5&&j>=0&&j<5)
        return true;
    return false;
}
void bfs()
{
    queue<Road> q;
    Road r;
    r.x=start.x,r.y=start.y;
    q.push(r);vis[r.x][r.y]=1;
    while(!q.empty())
    {
        Road temp=q.front();q.pop();
        if(temp.x==ed.x&&temp.y==ed.y)
        {
            return;
        }
        for(int i=0;i<4;i++)
        {
            int nx=temp.x+dx[i],ny=temp.y+dy[i];
            if(check(nx,ny)&&maze[nx][ny]=='0'&&!vis[nx][ny])
            {
                Road next;
                next.x=nx,next.y=ny;
                pre[next.x][next.y]=temp;
                q.push(next);
                vis[nx][ny]=1;
            }
        }
    }
}
void Print(Road step)
{
    if(step.x==0&&step.y==0)
    {
        cout<<'('<<0<<", "<<0<<')'<<endl;
        return;
    }
    Print(pre[step.x][step.y]);
    cout<<'('<<step.x<<", "<<step.y<<')'<<endl;
}
int main()
{
    for(int i=0;i<5;i++)
        for(int j=0;j<5;j++)
            cin>>maze[i][j];
    start.x=0,start.y=0;
    ed.x=4,ed.y=4;
    bfs();
    Print(ed);
    return 0;
} 

 

总结:通过这道题学到了记录路径的方法,通过一个结构体定义  起点,终点,路径;
    输出路径时用到递归,因为递归能到达最里面然后输出。
上一篇:迪杰斯特拉堆优化


下一篇:20200129模拟赛T1 string