POJ1159 Palindrome(数位DP)

Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 58277   Accepted: 20221

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

 
分析:

1.当S1==Sn时(字符串头字符和字符串尾部字符相等时),我们的任务便转换为了将S2,S3,S4……S(n-1)变成回文,对吗?

2.当S1!=Sn时,我们又有了两种决策

第一种决策:在字符串序列S1,S2,S3……Sn 的左边添加一个字符,我们设这个字符为Si,使它等于Sn,这样我们就将当前的任务转化为了将S1,S2,S3……S(n-1)变成回文字符串。

第二种决策:在字符串序列S1,S2,S3……Sn 的右边添加一个字符,我们设这个字符为Sk,使他等于S1,这样我们就将当前的任务转化为了将S2,S3,S4……Sn变成回文字符串。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[];
short int dp[][];
int dfs(int l, int r)
{ //printf("%d %d\n", l, r);
if(l >= r)
return ;
int m = ;
if(dp[l][r] != -)
return dp[l][r];
if(s[l] == s[r])
m = min(dfs(l+, r-), m);
else
{
m = min(dfs(l+,r)+, m);
m = min(dfs(l, r-)+,m);
}
dp[l][r] = m;
return m;
}
int main()
{
int n;
while(~scanf("%d", &n))
{
memset(dp, -, sizeof dp);
scanf("%s", s);
int len = strlen(s);
int ans = dfs(, len-);
printf("%d\n", ans);
}
return ;
}
上一篇:git基本命令--tag, alias,


下一篇:sort()基础知识总结+超简短的英文名排序写法