ZOJ2481 Unique Ascending Array 2017-04-18 23:08 33人阅读 评论(0) 收藏

Unique Ascending Array


Time Limit: 2 Seconds      Memory Limit: 65536 KB

Given an array of integers A[N], you are asked to decide the shortest array of integers B[M], such that the following two conditions hold.

  • For all integers 0 <= i < N, there exists an integer 0 <= j < M, such that A[i] == B[j]
  • For all integers 0 =< i < j < M, we have B[i] < B[j]

Notice that for each array A[] a unique array B[] exists.

Input

The input consists of several test cases. For each test case, an integer N (1 <= N <= 100) is given, followed by N integers A[0], A[1], ..., A[N - 1] in a line. A line containing only
a zero indicates the end of input.

Output

For each test case in the input, output the array B in one line. There should be exactly one space between the numbers, and there should be no initial or trailing spaces.

Sample Input

8 1 2 3 4 5 6 7 8

8 8 7 6 5 4 3 2 1

8 1 3 2 3 1 2 3 1

0

Sample Output

1 2 3 4 5 6 7 8

1 2 3 4 5 6 7 8

1 2 3

————————————————————————————————————

题目的意思是给出一个序列,输出去重后的排序好的序列

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <set>
#include <map>
#include <queue> using namespace std;
#define inf 0x3f3f3f3f int main()
{
int n,a[100005];
while(~scanf("%d",&n)&&n)
{
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
sort(a,a+n);
printf("%d",a[0]);
for(int i=1; i<n; i++)
if(a[i]!=a[i-1])
printf(" %d",a[i]);
printf("\n");
}
return 0;
}
上一篇:Word所有字体按比例缩小


下一篇:Java Native Interface Specification—Contents