L1-023 输出GPLT (20 分)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT…这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

代码如下:

#include <stdio.h>  
#include <string.h>  

int main()  
{  
    char a[10001];
    gets(a);
    int n=strlen(a);
    int G=0,P=0,L=0,T=0;
    for(int i=0;i<n;i++){
    	if(a[i]=='G' || a[i]=='g'){
    		G++;
    	}
    	if(a[i]=='P'|| a[i]=='p'){
    		P++;
    	}
    	if(a[i]=='L'|| a[i]=='l'){
    		L++;
    	}
    	if(a[i]=='T' || a[i]=='t'){
    		T++;
    	}
    }
    //打印
	while(G>0 || P>0 || L>0 || T>0){
		if(G>0){
			printf("%c",'G');
			G--;
		}
		if(P>0){
			printf("%c",'P');
			P--;
		}
		if(L>0){
			printf("%c",'L');
			L--;
		}
		if(T>0){
			printf("%c",'T');
			T--;
		}
	} 
    
    return 0;  
}  
上一篇:1067 试密码 (20 分)


下一篇:输出GPLT