HDU1879--继续畅通工程(最小生成树)

Problem Description

省*“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。

Output

每个测试用例的输出占一行,输出全省畅通需要的最低成本。

Sample Input

3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0

Sample Output

3
1
0

Author

ZJU

Source

浙大计算机研究生复试上机考试-2008年

又是最小生成树。。。。畅通工程==最小生成树

注意这道题目中有一些道路已经修建,而最终的结果是统计修路最少的花费,所以需要判断一下此路是否修建,若没修建,则在最终结果加上此条路的花费

代码

#include<iostream>
#include<algorithm>
#include<stdio.h>
#define MAXN 10000
using namespace std;
int s[MAXN];
int n,m;
struct edge
{
int x;
int y;
int v;
bool t;
}G[MAXN];
int f(int x)
{
if(x==s[x])
return x;
s[x]=f(s[x]);
return s[x];
}
int merg(int a,int b)
{
int x=f(a),y=f(b);
if(x!=y){
s[x]=y;
return 0;
}
return 1;
}
void init()
{
for(int i=0;i<=n;i++){
s[i]=i;
}
}
bool cmp(struct edge a,struct edge b)
{
return a.v<b.v;
}
int main()
{
#ifndef ONLINE_JUDGE
freopen("data.in", "r", stdin);
#endif
int a,b;
int res;
int round;
int flag;
while(scanf("%d",&n),n){
for(int i=0;i<=n;i++){
s[i]=i;
}
res=0;
round=n*(n-1)/2;
for(int i=0;i<round;i++){
scanf("%d%d%d%d",&G[i].x,&G[i].y,&G[i].v,&G[i].t);
if(G[i].t==1)
merg(G[i].x,G[i].y);
}
sort(G,G+round,cmp);
for(int i=0;i<round;i++){
a=f(G[i].x);
b=f(G[i].y);
flag++;
if(a!=b){
s[a]=b;
if(G[i].t==0)
res+=G[i].v;
if(flag==(n-1))
break;
}
}
// cout<<res<<endl;
printf("%d\n",res);
}
return 0;
}
上一篇:SQL Server 阻止了对组件 'Ad Hoc Distributed Queries' 的 STATEMENT'OpenRowset/OpenDatasource' 的访问


下一篇:压力测试+接口测试(工具jmeter)