【PAT】【简单进制转换】1019 General Palindromic Number (20 分)

 题目链接:1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

// raw word:

// palindromic回文  forwards转发(没有s为向前)   decimal小数   the decimal system十进制

// concept概念  notation符号

 

// 解题思路:

// 简单进行进制转换,遍历一遍判断是否回文,按要求输出结果即可

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
#define ll long long

vector<int> ans;
bool fun(int n, int b)
{
    // 进制转换,用vector保存
    vector<int> t;
    while(n)
    {
        t.push_back(n % b);
        n /= b;
    }
    bool flag = true;
    int cnt = t.size();

    // 判断是否为回文数
    for(int i = 0; i < cnt / 2 + 1; i++)
    {
        if(t[i] != t[cnt - 1 - i])
        {
            flag = false;
            break;
        }
    }
    // 赋给答案数组
    ans = t;
    return flag;
}
int main()
{
    // 读入数据
    ll n, b;
    scanf("%lld %lld", &n, &b);

    // 输出答案
    if(fun(n, b)) printf("Yes\n");
    else printf("No\n");

    // 打印b进制下的数字
    for(int i = ans.size() - 1; i >= 0; i--)
    {
        if(i == 0)
        printf("%d", ans[i]);
        else
        printf("%d ", ans[i]);
    }
    return 0;
}

 

上一篇:PAT 甲级 1019 General Palindromic Number


下一篇:[LeetCode] 5. Longest Palindromic Substring _Medium tag: Two pointers