HDU-2717,Catch That Cow(BFS)

Problem Description:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it? 

Input: 

Line 1: Two space-separated integers: N and K 

Output: 

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow. 

Sample Input: 

5 17 

Sample Output: 

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes. 

程序代码: 

#include<iostream>
#include<queue>
#include<cstring> 
using namespace std;
#define maxn 100001
bool vis[maxn];
int step[maxn];
queue<int> q;//定义队列 
int bfs(int n,int k)
{
    int head,next;
    q.push(n);//n入队 
    step[n]=0;
    vis[n]=true;
    while(!q.empty())//当队列非空 
    {
        head=q.front();//取队首 
        q.pop();//出列 
        for(int i=0;i<3;i++)
        {
            if(i==0)
                next=head-1;
            else if(i==1)
                next=head+1;
            else
                next=head*2;
            if(next<0||next>=maxn)
                continue;
            if(!vis[next])
            {
                q.push(next);
                step[next]=step[head]+1;
                vis[next]=true;
            }
            if(next==k)
                return step[next];
        }
    }
}
int main()
{
    int n,k;
    while(cin>>n>>k)
    {
        memset(step,0,sizeof(step));
        memset(vis,false,sizeof(vis));
        while(!q.empty())
            q.pop();//调用前先清空 
        if(n>=k)
            cout<<n-k<<endl;
        else
            cout<<bfs(n,k)<<endl;
    }
    return 0;
}

 

上一篇:markdown使用下使用mermaid做图


下一篇:Balanced Lineup